
 
 

 
3236 Rev A 

Page 1 of 29 

Knowledge Base Article 
 
Product Group: Multilog On-Line Systems  
Product: WMx 
Version: N/A 
 
 

Abstract 
The WMx is an SKF Multilog On-Line System that provides early fault detection 
and prevention when used in conjunction with SKF @ptitude Analyst.  This 
article outlines the process and utilities that are required to set up a WMx device 
with @ptitude Analyst.   
 
  
Overview  
The WMx is a compact, eight-channel data acquisition device that communicates 
with @ptitude Analyst using an existing wireless network.  [Figure 1]  The SKF 
@ptitude WMx Service facilitates the communication between the WMx device 
and the software.  
 
 

 
Figure 1. These devices communicate with SKF @ptitude Analyst 

over a wireless network using SKF @ptitude WMx Service. 
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The steps listed below outline the procedure and describe the utilities required in 
setting up a WMx device: 
 
Setting up WMx Hardware 

1. Install the WMx hardware.  
 
 Refer to the WMx hardware user manual for details. 

 
Setting up SKF @ptitude Analyst 

1. Install SKF @ptitude Analyst 2012 or later from the DVD. 
 

2. Please use either 7400 or 7300 license keys to access and enable WMx 
functionality.  

 
Setting up SKF Transaction Service 

1. Once @ptitude Analyst has been installed and the database connection 
has been set, go to Start > All Programs > SKF @ptitude Monitoring 
Suite > Admin Tools > SKF @ptitude Configuration Tool. 

 
2. Select SKF @ptitude Transaction Service.  [Figure 2]  Next, select the 

service from the list in the right pane, and then click Start to start the 
Transaction Service.  If there are no services listed, click Add to create a 
new service. 

 
 

 
Figure 2. SKF @ptitude Transaction Service 
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Setting up the WMx Service 

1. Set up a wireless network for the service to communicate through. 
 
2. In SKF @ptitude Configuration Tool, select SKF @ptitude WMx Service.  

[Figure 3] 
 
 

 

 

Figure 3. SKF @ptitude WMx Service 
 
 

3. A small message box will be displayed.  [Figure 4]  This message states 
the legacy data from Wireless DB Builder can be imported using the 
skfWMxConversionUtility.exe utility. The message also specifies the 
location where this utility can be found.  

 
4. The same message also informs the user that the port for the WMx 

service must not be blocked by firewall software. 
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 Figure 4. WMx Service message 

 
 
5. Uncheck Show this message again to avoid seeing the message each 

time SKF @ptitude WMx Service is visited. 
 

6. Click OK to continue. 
 

7. Only one WMx Service can be created in @ptitude Analyst.  To create a 
new service, click Add.  [Figure 5] 

 
 

Figure 5. SKF @ptitude WMx Service Configuration 
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8. The new service details will appear in the Properties section.  [Figure 6] 
 
 

 

 

Figure 6. Creating a new service 
 
 
9. Name and Host are set to default values and cannot be changed. Name 

is set as [default] and Host is set as the PC name.   
 
10. Service port is set as 8000 by default, and Internal port is set as 8001.  

These values can be changed.   
 

 Ensure that the service port assigned to the service is not 
blocked by firewall software. 

 
 If these port values are changed, the same port values must also 

be changed in the WMx using WMx Wireless Configuration 
Utility. 

 
11. Select the Connection title.  This is the database the WMx service will 

communicate with. 
 
12. Localhost IP address is just there for reference and regardless of what is 

chosen there, the service will listen across all appropriate TCP/IP. 
 
13. To revert back to the default settings, click Undo.  Otherwise, to save the 

changes and create the service using these settings, click Save.  
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14. After a few moments of processing, a message will be displayed 

confirming that the service is starting.  [Figure 7]  Click OK to continue. 
 
 

 
Figure 7. Service is starting  

 
 
15. Once the service is created and started, it will be visible in the list.  

[Figure 8]. 
 
 

 
Figure 8. List of WMx Services 
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At this point, the buttons displayed underneath the services list can be used 
for the following functions: 
 

• Stop – Stop the service. 
 

• Edit – Edit the settings of a service.  To edit, select a service from 
the list and click Edit.  After making the necessary changes, click 
Save or else click Undo to revert those changes. 

 
• Deactivate/Activate – Deactivate or activate a service.  Deactivating 

a service will unregister the service from Windows Services; 
however, the details of the service will still exist in @ptitude Analyst.  
After deactivating a service, the Deactivate button will be replaced 
by an Activate button.  Activating a service will register the service 
again in Windows Services. 

 

 
• Remove – Remove a service from Windows Services and @ptitude 

Analyst. 
 

16. Before leaving this section, ensure that the WMx service is running. 
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Unblocking Windows Built-In Firewall Settings 
Note: This will require administration rights on the computer.  
 
The information below is valid for the Built-In firewall of the Windows version 
only. To enable the ports on a different firewall, check the documentation of the 
firewall in use. 
 

For Windows XP 

1. Go to Start > Control Panel. 
 
2. Double-click Windows Firewall. 

 
3. Select the Exceptions tab. 

  
4. Click the Add Port button. 

 
5. Enter a name in the Name field. 

 
6. Enter a number in the Port Number field.  Make sure this is the 

same number which was chosen in the SKF @ptitude Configuration 
Tool for SKF WMx Service-Service Port. 

 
7. Select TCP. 

 
8. Click OK. 

 
 

For Windows Vista 

1. Go to Start > Control Panel. 
 
2. Double-click Windows Firewall. 

 
3. Select the Exceptions tab. 

 
4. Click the Add Port button. 

 
5. Enter a name in the Name field. 

 
6. Enter a number in the Port Number field.  Make sure this is the 

same number which was chosen in the SKF @ptitude Configuration 
Tool for SKF WMx Service-Service Port. 

 
7. Click TCP. 
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8. Click OK. 

 
 
For Windows 7 

1. Go to Start > Control Panel. 
 

2. Click System and Security. 
 

3. Click Windows Firewall. 
 

4. Click Advanced Settings. 
 

5. Click Inbound Rules and select New Rule. 
  

6. Select Port and click Next. 
 

7. Select TCP and Specific Local Ports. For Port number, enter the 
same number which was chosen in the SKF @ptitude Configuration 
Tool for SKF WMx Service-Service Port. 

 
8. Click Next. 

 
9. Select Allow the Connection. 

 
10. Click Next. 

 
11. Domain, Private, and Public profile are selected.  Do not change 

this. 
 

12. Click Next. 
 

13. Enter a Name and Description of the rule (i.e. ‘WMx service port 
rule’). 

 
14. Click Finish.  
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Importing Legacy Data 

1. Go to the location where @ptitude Analyst is installed and launch the 
SKF WMx Conversion Utility. 

 
 Windows XP - The default installation location is ‘C:\Program 

Files\SKF-RS\SKF @ptitude Analyst’ 
 

 Windows 7 - The default installation location is ‘C:\Program 
Files(x86)\SKF-RS\SKF @ptitude Analyst’ 

 
Note: If the default installation directories are not used, go to 
the directory where the application is installed. 

 
 

 Select the WMx Conversion Utility:  
 
2. Login using SKF @ptitude Analyst credentials.  Only users with import 

access privileges will be allowed to import data.   
 
3. Select the Destination hierarchy in @ptitude Analyst where the data 

will be imported to.  Next, select the Import source, which is the DB 
Builder Access database where the data will be imported from.  [Figure 
9] 

 
4. The option Save processing details to WMxConversionUtility.log is 

checked by default.  This should not be changed.   
 

5. Click Next.   
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Figure 9. Importing legacy data 
 
 

Note: Only databases with version 12 or greater can be imported.  If a 
database is of an older version, the database must first be upgraded using 
DB Builder V2.1.1. 
 
 
6. On the import status screen, click Next. 
 
7. Allow the import to finish, or click Cancel to stop the import process.   

 
8. Once the import is complete, an import summary screen will be 

displayed.  Click Finish.  
 

9. To view the details from the import, login to @ptitude Analyst and 
expand the hierarchy where the POINTs were imported.  The DB Builder 
POINT setup has been converted to Set/Machines and POINTs under 
this hierarchy. 
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Setting up the Network Details for the WMx Device 

1. The WMx Wireless Configuration Utility will be required in order to 
connect a device and change its network/wireless settings.   

 
 WMx Wireless Configuration Utility does not require a connection to 

a wireless network. Note that this software in installed as part of the 
standard @ptitude Analyst installation. 

 
 The WMx device should be connected when installing the utility on a 

Windows XP machine.  If the device is not connected when the utility 
is installed, a New Hardware Dialog will be displayed when the 
device is connected for the first time.  When the New Hardware 
dialog appears, select the device driver from the DVD, found at 
location - Tools\WMx\WMx USB Drivers.  

 
 The utility can be installed/found in a few different ways: 

 
• As part of the @ptitude Analyst 2012 installation - The utility 

can be found under Start > SKF @ptitude Monitoring Suite > 
Admin Tools.  

 
• Using the @ptitude software DVD - Even for those users who do 

not install the full @ptitude Analyst application, the utility itself 
can still be installed from the DVD.  Under Tools\WMx\SKF 
WMx Wireless Configuration Utility, select the package SKF 
WMx Wireless Configuration Utility (x64) for a 64-bit machine 
or else SKF WMx Wireless Configuration Utility for a 32-bit 
machine.  

 
• Using the hardware CD that was shipped with the device. 

 
• By downloading the installation file from the SKF website. 

 
2. The installation will create a shortcut to the utility on the desktop.  

Launch the Wireless Configuration Utility by clicking on this shortcut.   
 

3. Choose the configuration under Configuration Options.  [Figure 10] 
 

 If connecting a WMx device, use a USB cable and select 
Configure using USB cable. 

 
 If connecting a WVT device, use a serial cable and select 

Configure using serial cable.  
 

SKF Reliability Systems
5271 Viewridge Court  *  San Diego, California, 92123 USA
Telephone 1-800-523-7514  Web: www.skf.com



 
 

 
3236 Rev A 

Page 13 of 29 

 
4. Next, enter the TCP port.  This will be the same port number that was 

configured for the WMx Service.   The default port value is 8000.  Click 
Start when ready. 

 
 

 

 

Figure 10. Wireless Configuration Utility 
 
 
5. Once the device is connected, it will be displayed in the Configuration 

Utility under Wireless Devices Detected.  [Figure 11]  The device name 
can be changed from within the utility.   
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Figure 11. Wireless devices detected 

 
 

6. To set up a device to connect with WMx Service, the following settings 
must be configured: 

 
Network Settings: 

• Select Obtain an IP Address Automatically if a dynamic IP 
address will be used.   

 
• If a static IP address is being used, select Use the following IP 

Address, and then enter the IP Address that is to be used for 
the WMx unit.  It is recommended that you use a static IP 
address to optimize battery life by reducing connection time. 

• Under Host Server, enter the Host IP address and Host Port of 
the host computer.  The host computer running the WMx 
Service must be assigned a static IP address. Host Port should 
be the WMx service port number. 
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Wireless Network: 

• If a structured wireless network is being used, select the 
Structured Network (Access Point) option button.  It is 
recommended that a structured wireless network be used.  If a 
structured network has been chosen, enter the wireless network 
name in SSID. 

 
• If a peer-to-peer wireless network is being used, select the Ad-

hoc Network (Peer-to-Peer) option button.  
 
• Select the network encryption type under Security. This will 

allow the configuring of data encryption, which encodes the data 
passing to and from the WMx. 

  
• Check the option Make Changes only when the WMx device is 

being setup for the first time, or when the device is supposed to 
connect to a new Access Point configuration.  

 
• For making changes, select the Security as set up for the Access 

Point: Disabled; WEP 64 bit; WEP 128 bit; WPA-PSK; or WPA2-
PSK.  WEP is the least secure, while WPA2/PSK is the strongest 
encryption protocol.  The selection of the encryption is dictated 
by the Access Point which the WMx is being set up to 
communicate with. 

 
• After selecting the security type, enter the password key.  For 

security type WPA/PSK and WPA2/PSK, simply enter a pass 
phrase.  For security type WEP, select 64/128 bit encryption 
from the WEP Security dropdown.  Four password keys are to 
be entered in Key 1 through Key 4.  Fill these fields with the 
same password key.  [Figure 12] 
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Figure 12. Wireless network settings 
 
 

• Select Open or Shared authentication as per the setting in the 
Access Point.  It is recommended that the authentication in the 
Access Point is set up as Open, because it is more secure. 

 
• The settings are now complete.  Click the Connect to Host 

button.  [Figure 13] 
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Figure 13. Connect to Host 
 
 
7. A connection log will be displayed in the right pane.  This log will display 

the connection status to the wireless network and the host.  Ensure 
that the WMx Service is started on the host machine.  The log 
mentions a ‘Remove cable to disconnect’ message.  Please ignore this 
message.  Do not remove the USB/Serial cable.  If the cable is removed, 
the Utility will no longer be connected.   

 
8. If connection to the host was successful, this will be indicated in the log 

by an ‘Established connection to host’ message.  [Figure 14]  This 
message relays that the device has connected to the WMx service.  At 
this point the USB/Serial cable can be removed.   

 
 

 
 
 
 
 
 
 
 
 
 

SKF Reliability Systems
5271 Viewridge Court  *  San Diego, California, 92123 USA
Telephone 1-800-523-7514  Web: www.skf.com



 
 

 
3236 Rev A 

Page 18 of 29 

 

  
Figure 14. Established connection to host 

 
 

9. For any further details about WMx Wireless Configuration utility, refer to 
the WMx Hardware manual in the WMx hardware CD. 
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WMx Devices in @ptitude Analyst 

1. When devices are connected to the WMx Service, they can be seen in 
@ptitude Analyst. 

 
2. To view these devices, go to View > WMx Device…  

 
3. A dialog will be displayed with a list of available WMx devices.  [Figure 

15] 
 
 

 

 

Figure 15. WMx devices in @ptitude Analyst 
 
 
Changing Device Details in Analyst 

1. Select a WMx device from the list, and then click Edit.  The Device 
Properties window [Figure 16] will be displayed.  This window provides 
the settings of the selected device. 
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Figure 16. Device Properties window 
 
 

2. Make the appropriate changes to the device and/or channel settings by 
selecting the appropriate tabs.  When done, click OK.   

 
 Reference the user manual for more details on the WMx Device 

Properties settings.  The manual (UM_AA_OLS_<4 
digit/character language code>) can be found on the DVD under 
UserManuals/<Language folder>. 
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Creating WMx POINTs in Analyst 
WMx POINTs can be created in @ptitude Analyst.  
 

1. Go to Insert > New POINT.    
 
2. In the DAD/POINT Type Selection window [Figure 17], choose WMx as 

the DAD type.  Select the Application, Sensor type, and Units as 
appropriate for the WMx POINT type.  Click OK when done. 

 
 

 

 

Figure 17. DAD/POINT Type Selection 
 
 

3. The POINT Properties dialog will be displayed.  [Figure 18]  The General 
tab will contain the identity details of the POINT type.  Set the Name and 
Description as desired. 
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Figure 18. POINT Properties window 
 
 

4. Next, go to the Setup tab and select the appropriate Device and 
Channel name.  [Figure 19]  Change any other setup details as desired. 

 
 Reference the user manual for more details on POINT setup.  

The manual (UM_AA_OLS_<4 digit/character language code>) 
can be found on the DVD under UserManuals/<Language 
folder>. 
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Figure 19. POINT Properties setup 

 
 

5. Click OK after the desired changes are made.  The POINT is now 
assigned to the device and will begin collecting data according to the 
wakeup interval of the selected WMx/WVT device.  

 
6. WMx devices also support diagnostic POINTs.  The POINT types which 

come under this category are: Battery level; Noise level; Signal level; and 
Signal quality.  Only battery level POINTs are also supported by WVT 
devices. 
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Troubleshooting 
 
Problem 
#1 

The device is not connecting to the WMx Service.  It is not 
showing up in @ptitude Analyst either. 

Solution Verify the IP Address of the computer where the WMx Service 
has been installed.  This should be the same as the Host IP 
Address that was set up in the WMx device in WMx Wireless 
Configuration Utility.  If these IP addresses do not match, change 
the Host IP and Host Port configuration in the WMx device to 
match the IP address of the Host machine and WMx service port. 

 Verify the Service Port for the WMx Service.  This should be the 
same as the Host Port that was set up for that device in WMx 
Wireless Configuration Utility.  If the ports do not match, change 
the configuration of the WMx device. 

 Verify the wireless connection is configured correctly and that the 
connectivity is good on the host machine as well as on the WMx 
device. 

 Ensure that the WMx Service port not being blocked by any 
firewall software. 

 Check LEDs on the WMx board to determine if the WMx sees the 
network and the Host. 

 

 
Problem 
#2 

The device is sending data but the measurements take a while to 
show up in @ptitude Analyst. 

Solution If the measurements are showing up late, the WMx Service is 
receiving measurements at a higher rate than which they can be 
processed.   
 
Try setting the wakeup interval for the WMx devices so that they 
collect at different wakeup intervals, preferably at an interval 
greater than five (5) minutes.  This can be set up by editing the 
WMx’s Wake Up Interval.  
 
For systems with a large number of WMx devices, it is 
recommended to stagger the synchronization of each unit by a 
few minutes.  This prevents all of the WMx units from waking up 
together and trying to connect to the host computer 
simultaneously.  Battery life is also optimized if WMx units are 
not waiting to be serviced by the host.  For this, wake-up interval 
times can be offset by editing the WMx’s Wake Up Sync Time 
value on SKF @ptitude Analyst > View > WMx Device… > Edit 
Device Properties dialog.  
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A few examples: 
 

• If Wakeup Sync Time is set to a time of 13:15:00 
(HH:MM:SS) and the Wakeup interval is set to two hours, 
and the time now is 23:55 pm, then the WMx unit will 
wake up at 13:15 and every two hours thereafter (13:15, 
15:15, 17:15, etc..).  

• If Wakeup Sync Time is set to a time of 13:15:00 
(HH:MM:SS) and Wakeup interval is set to two hours, and 
the time now is 17:00, then the WMx unit will wake up at 
17:15 and every two hours thereafter (17:15, 19:15, 
21:15 etc.). 

• If Wakeup Sync Time is set to a time of 01:00:00 
(HH:MM:SS) and Wakeup interval is set to 6 hours, and 
the time is now 23:55 pm, then the WMx will wakeup at 
01:00 and every six hours thereafter(01:00, 07:00, 
13:00 etc.). 

 

 

 
Problem 
#3 

The SKF @ptitude WMx Service is showing high memory usage in 
the Task Manager. 

Solution Conduct the same steps as outlined in Problem #2 above. 
 
Problem 
#4 

The device is not collecting data for POINTs. 

Solution Make a minor change to the POINT setup and then check the log 
file located in <Shared App Data Path>/SKF/@ptitude 
Analyst/Log/WMx.  The file name will be of the format 
YYYY_MMM_DD.  The log file will contain the recently downloaded 
XML configuration.  If there is a configuration error recorded after 
it, fix the issue in the POINT setup. 
 
Shared App Data Path on Windows XP: 
C:\Documents and Settings\All Users\Application Data\ 
 
Shared App Data Path on Windows 7: 
C:\ProgramData\ 
 
If there are no configuration errors, check the WMx Non-
Collection preferences.  If the collection schedule for the 
anticipated non-collection event is set to Never, try changing it to 
Always.  
 
For example, if BOV out of range is expected in the 
measurements, and the preference is set to Always, then the 

SKF Reliability Systems
5271 Viewridge Court  *  San Diego, California, 92123 USA
Telephone 1-800-523-7514  Web: www.skf.com



 
 

 
3236 Rev A 

Page 26 of 29 

non-collection measurement would always be stored. If the 
preference is set to Onchange, it would only be stored when it 
first occurs and when the BOV condition is cleared.  If the 
preference is set to Never, then the non-collection measurement 
would never be stored. 
 
Note: The default values of these preferences are set to Always, 
which is also the recommended selection. 

 
Problem 
#5 

POINTs are collecting ‘BOV out of range’ non-collection 
measurements.   

Solution Check the BOV value for the POINT by going to Plots > All Plots 
> BOV or Gap plot.  Compare this value with the BOV lower and 
upper range for the selected channel under Device Properties > 
Channels tab. The recommended action is to fix the sensor. 

 

 
Problem 
#6 

POINTs are collecting ‘Outside of threshold range’ non-collection 
measurements. 

Solution Check the threshold ranges in POINT Properties > Threshold 
tab.  Check the overall value of the reference point and compare 
it with the active range. Take appropriate action based on this 
information. 

 
Problem 
#7 

The device is returning trigger timeouts for POINTs. 

Solution This happens when the WMx point is collecting speed based on 
the selected tacho channel. 
 
To review these settings, go to POINT Properties > Setup tab. If 
speed does not need to be collected, then uncheck Enable 
Tacho.  Otherwise, to collect Speed, ensure Enable Tacho is 
checked and a Tacho channel on which speed must be collected 
is selected.  Also, ensure that the physical WMx device is set up 
to collect a non-zero speed for that channel.  If the physical setup 
is not correct, then ‘Trigger Timeout’ non-collection 
measurements would be collected. 
 
Once the setup is correct, the measurements record the speed as 
the speed which is collected on the tacho channel.  If Enable 
Tacho is unchecked, then the speed of the point which is present 
on POINT properties > Setup tab is stored with the 
measurements. 
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Problem 
#8 

The device is returning channel overload for POINTs. 

Solution The input is exceeding the maximum input voltage range (e.g. 
when a fixed range is set for dynamic channels or when there is 
an open circuit at the DC input terminals, an overload event may 
occur).  To start bringing in measurements, either try increasing 
the full scale range to a more appropriate level in the POINT 
setup, or turning on Autorange in POINT Properties > Setup 
tab to resolve the overload. 

 
Problem 
#9 

@ptitude Analyst WMx Device dialog will not allow me to change 
the name of the device.   

Solution The device name for WMx/WVT devices can only be changed 
from within WMx Wireless Configuration Utility.  When the name 
is changed in the utility, @ptitude Analyst is automatically 
updated with this new information upon the next time the WMx 
connects. 

 

 
Problem 
#10 

A WMx device is not functioning correctly and needs to be 
replaced.  How can I retain the POINTs and channel 
configurations when replacing the hardware?   

Solution Connect the new device to SKF @ptitude WMx Service.  Once the 
new device shows up in @ptitude Analyst, go to the old device, 
open Device Properties and click Swap.  Next, select the new 
device from the list and click OK.  Save the device properties. The 
new device will now be assigned to the same set of POINTs and 
channel configuration as the old device. 

 
 
Problem 
#11 

How can I see the trend of WMx device diagnostic POINTs?  Is 
there a way to track the battery level? 

Solution WMx diagnostic POINTs can be created in @ptitude Analyst by 
selecting WMx > General > Battery level/ Noise level/ Signal 
level/ Signal Quality.  Assign the appropriate device to these 
POINTs.  Each WMx device should have only one Battery level, 
one Noise level, one Signal level and one Signal Quality POINT.  
These diagnostic POINTs are collected together with each 
wakeup or measurement cycle, and can be trended in @ptitude 
Analyst. Please use the trend plot to view the trend of this 
diagnostic information. 
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Problem 
#12 

Can I create a WMx device in @ptitude Analyst even when the 
physical device is not available? 

Solution Yes, @ptitude Analyst 2012 provides a capability to create new 
WMx/WVT devices in Analyst. 

1. Please go to View > WMx Devices menu item.  
2. A dialog appears with a tree structure on the left side. 

Click on the WMx devices node in the tree structure.  
3. Three tabs open up on the right side. Click on the tab 

named ‘WMx Devices’.  
4. Click on the Add button. 
5. A new device properties dialog is displayed. Go to the 

Devices tab. 
6. If the Mac address of the physical WMx device is known, 

please uncheck ‘No Mac address’ checkbox and enter the 
Mac address. Otherwise, leave the ‘No Mac address’ 
checkbox checked. 

 

 
 
Problem 
#13 

Where can we find the Download and Upload XML? 

Solution Download and Upload XML are not stored by default. This 
functionality should only be turned on for debugging purposes. 
For enabling this, please set the following keys 
skfWMxService.exe.config: 
KeepDownloadsWeeks = value greater than 0 (for example : 2) 
KeepUploadsWeeks = value greater than 0 (for example : 2) 
 
(For Windows XP - skfWMxService.exe.config can be found at 
‘C:\Program Files\SKF-RS\SKF @ptitude Analyst’) 
 
(For Windows 7 – skfWMxService.exe.config can be found at 
‘C:\Program Files (x86)\SKF-RS\SKF @ptitude Analyst’) 

 
 
Problem 
#14 

Where can I find the log files for WMx service? 

Solution There are two sets of log files maintained for WMx service. These 
can be found at <Shared App Data Path>\SKF\@ptitude 
Analyst\Log\WMx\. The file names for these files are in this 
format: 

• YYYY_MMM_DD.log 
• default YYYYMMDDHHMMSS.log – This log file is enabled 

by default.  To disable, set the ‘WriteCommsLogFile’ key 
to false in the skfWMxService.exe.config. 
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(For Windows XP - skfWMxService.exe.config can be found at 
‘C:\Program Files\SKF-RS\SKF @ptitude Analyst’) 
 
(For Windows 7 – skfWMxService.exe.config can be found at 
‘C:\Program Files (x86)\SKF-RS\SKF @ptitude Analyst’) 

 
 
Problem 
#15 

The WMx service displays high memory usage?  Is there a way to 
fix this? 

Solution Please refer the ‘WMx Service Memory Watch’ section in the user 
manual. The manual (UM_AA_OLS_<4 digit/character language 
code>) can be found on the DVD under 
UserManuals/<Language folder> 

 
  

 
---- 
 
For further assistance, please contact the Technical Support Group by phone at 
1-800-523-7514 option 8, or by email at TSG-Americas@skf.com. 
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